iOS - 安装GBA4iOS的2种方法

最近想玩玩GBA上的口袋妖怪,发现GBA4iOS这个开源项目,由于模拟器存在法律问题,这款软件并没有在 AppStore 上架,所以需要一点手段才可以安装。

官网:http://www.gba4iosapp.com/

不建议玩家使用国内的XX助手来安装这个游戏,更不建议大家在电脑或者手机里装这些助手,安全问题大家都懂的,我这里提供两种方法,一种只需要在手机上即可完成,一种是使用xcode编译源码安装。

手机安装

Safari 打开 GBA4iOS 官网

点击下载,安装

下载失败,把系统时间调至2012年的某一天

继续安装

很遗憾,安装完后打不开,我们需要授权

授权

设置>通用>设备管理>ChniaVID(Beijing) Technology

授权失败,把系统时间设置为自动

再次授权

设置>通用>设备管理>ChniaVID(Beijing) Technology

这个时候就能授权成功啦

再次把系统时间调至2012年的某一天

然后就可以愉快的玩耍啦

注意事项

这种方法有个弊端,每次玩的时候都得把时间往前调,才可以玩。

编译安装

由于是开源项目,所以编译安装才是正道,现在真机调试已经不需要花99$注册开发者,如果你有一台Mac,就可以进行下一步。

下载源码

1
$ git clone https://bitbucket.org/rileytestut/gba4ios.git GBA4iOS

安装 cocoapods

1
2
$ ~ pod --version
1.0.1

安装方法自行Google,不是本文的重点,我安装的目前最新版本,1.0.1。

修改 Podfile

安装完,cocoapods后执行pod install,会出现错误,原因是pod版本太高,不支持之前一些语法了,所以先把Podfile修改成下面的内容,注意:可能官方会更新各个第三方库,下面的版本应该替换成原文件里面指定的版本。

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
source 'https://github.com/CocoaPods/Specs.git'
platform :ios, "9.0"
target 'GBA4iOS' do
pod 'RSTWebViewController', :git => 'https://github.com/rileytestut/RSTWebViewController-Legacy.git'
pod "AFNetworking", "~> 2.4"
pod "PSPDFTextView", :git => 'https://github.com/steipete/PSPDFTextView.git'
pod "Dropbox-iOS-SDK", "~> 1.3.13"
pod "CrashlyticsFramework", "~> 2.1.0"
end
target 'GBA4iOS-Simulator' do
pod 'RSTWebViewController', :git => 'https://github.com/rileytestut/RSTWebViewController-Legacy.git'
pod "AFNetworking", "~> 2.4"
pod "PSPDFTextView", :git => 'https://github.com/steipete/PSPDFTextView.git'
pod "Dropbox-iOS-SDK", "~> 1.3.13"
pod "CrashlyticsFramework", "~> 2.1.0"
end

执行 pod install

这一步是下载依赖项目,根据你的网速,耐心等待。

编译源码

双击 GBA4iOS.xcworkspace 打开 xocde

修改配置信息

修改 Bundle Identifier xxx.xxx.GBA4iOS 即可

报错处理

不出意外会报下面的错误

删掉 libPods.a 即可

插上手机,安装到手机

愉快的玩耍

Gavin Liu wechat
欢迎您扫一扫上面的二维码,订阅我的微信公众号!